AMP

From Omnia
Jump to navigation Jump to search

AMP - Application Management Panel

https://cubecoders.com/AMP

Supported Applications Compatibility

Supported Applications Compatibility
https://discourse.cubecoders.com/docs?topic=1828

Installation

CubeCoders | AMP Installation
https://cubecoders.com/AMPInstall

As root:

bash <(wget -qO- getamp.sh)

May need to first update locale (TUI):

dpkg-reconfigure locales && locale-gen
  # select en_US.UTF-8
reboot

--

More details about updating locate manually from console (no TUI):

# Install locales:
sudo apt-get install -y locales
# list locales: (likely missing en_US.UTF-8)
sudo locale -a
# generate locale: (if misisng)
sudo locale-gen en_US.UTF-8
# update:
sudo update-locale LANG=en_US.UTF-8
# reboot to apply change (doesn't seem to take effect until reboot??)
reboot

Restart AMP

sudo service ampinstmgr status
sudo service ampinstmgr stop
sudo service ampinstmgr start
# OR
sudo service ampinstmgr restart
sudo service ampinstmgr status

---

sudo su -l amp
ampinstmgr status
ampinstmgr --StopAllInstances
ampinstmgr --StartallInstances
ampinstmgr start ADS
ampinstmgr View ADS01

View ADS Console

ampinstmgr View ADS01

Web Interface

http://ampserver:8080/

List Instance Details

ampinstmgr list

Includes running status, amp version, start on boot, etc

Toggle Instance Start at Boot

ampinstmgr SetStartBoot [INSTANCE]

Upgrade AMP

Upgrade AMP service packages:

sudo apt update
sudo apt upgrade
# sudo apt upgrade ampinstmgr
sudo yum update
# sudo yum update ampinstmgr

Upgrade All Instances:

sudo su -l amp
# ampinstmgr upgradeall
ampinstmgr --nocache upgradeall

Is this needed?

# ampinstmgr upgrade INSTANCE
ampinstmgr upgrade ADS
ampinstmgr start ADS
ampinstmgr stopall
ampinstmgr startall

---

ampinstmgr stopall
ampinstmgr start ADS

---

ref: [1]

Upgrade

sudo su -l amp
# ampinstmgr stopall
ampinstmgr stop ADS
ampinstmgr --nocache upgradeall
ampinstmgr upgrade ADS
ampinstmgr start ADS
# combined:
ampinstmgr stop ADS ; ampinstmgr --nocache upgradeall ; ampinstmgr upgrade ADS ; ampinstmgr start ADS
ampinstmgr status

Force Manual Upgrade

wget https://downloads.cubecoders.com/AMP/Mainline/20231126.1/AMP_x86_64.zip -O AMP_x86_64.zip
ampinstmgr upgradeall

Apt Upgrade AmpInstMgr

echo "deb [signed-by=/usr/share/keyrings/repo.cubecoders.com.gpg] https://repo.cubecoders.com/ debian/" > /etc/apt/sources.list.d/repo.cubecoders.com.list
wget https://repo.cubecoders.com/archive.key -O /usr/share/keyrings/repo.cubecoders.com.gpg
 #  ### wget -qO - https://repo.cubecoders.com/archive.key | sudo apt-key add -
apt update
apt install ampinstmgr
apt upgrade ampinstmgr
systemctl restart ampinstmgr
systemctl status ampinstmgr

-

/etc/apt/sources.list.d/repo.cubecoders.com.list

deb [signed-by=/usr/share/keyrings/repo.cubecoders.com.gpg] https://repo.cubecoders.com/ debian/

Manually Upgrade AmpInstMgr

If apt upgrade ampinstmgr doesn't work...

Find latest:

https://repo.cubecoders.com/
curl -s https://repo.cubecoders.com/ | grep -o "ampinstmgr-\([a-z0-9._]*\).deb"

Deb install:

https://repo.cubecoders.com/
wget https://repo.cubecoders.com/ampinstmgr-2.4.6.8.x86_64.deb
sudo dpkg -i ampinstmgr-2.4.6.8.x86_64.deb

Upgrade to Nightly

sudo su -l amp
ampinstmgr switch INSTANCENAME Nightly
ampinstmgr --nocache upgradeall
ampinstmgr switch ADS01 Nightly

Switch back to mainline:

ampinstmgr switch INSTANCENAME MainLine True
ampinstmgr switch ADS01 MainLine true
ampinstmgr upgrade ADS
ampinstmgr start ADS

ref: [2]

Reset User Password

  1. Log onto your server using ssh.
  2. Log in as the amp user (sudo su - amp)
  3. Navigate to /opt/cubecoders/amp.
  4. Discover the name of your AMP instance using ./ampinstmgr --ShowInstancesTable - for me it was ADS01.
  5. Reset the password using ./ampinstmgr --ResetLogin.
  6. In my case, I had to reactivate the instance using ./
ampinstmgr --ShowInstancesTable
ampinstmgr --ResetLogin
ampinstmgr --StartInstance ADS01

ref: https://support.cubecoders.com/thread/how-do-i-perform-a-password-reset-on-the-amp-admin-user/

.profile

export TERM=xterm
export PS1=" \[\e[30;41m\]\[\e[m\]\[\e[37;41m\] CubeCoders AMP \[\e[m\]\[\e[31;44m\]\[\e[m\]\[\e[44m\] 💻\u\[\e[m\]\[\e[44m\]@\[\e[m\]\[\e[44m\]\h \[\e[m\]\[\e[34;42m\]\[\e[m\]\[\e[30;42m\] 📁\w \[\e[m\]\[\e[32;40m\]\[\e[m\] "
alias sudo="echo You cannot use sudo while logged in as the \'amp\' user, you need to be logged in as an administrator/root user do to that.;#"

Install Amp Supported Java Versions

Docker Java:

docker pull cubecoders/ampbase:java

Run: [1]

bash <(wget -qO- getamp.sh) installJava

"AMP uses Adoptium JDK and fetches multiple versions to cover different types of Minecraft server. Generally you want to use JDK17 for recent MC versions."

Issues

Can't find custom attr constructor image ADSModule.dll

Message in startup logs:

amp ampinstmgr[18466]: [Info] Stream: Mainline / Release - built by CUBECODERS/buildbot on CCL-DEV
amp ixota ampinstmgr[18466]: Can't find custom attr constructor image: /opt/cubecoders/amp/plugins/ADSModule.dll mtoken: 0x0a00001e due to: Could not load file or assembly 'SQLite-net, Version=1.0.0.0, Culture=neutral, PublicKeyToke, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
amp  ampinstmgr[18466]: [Info] Waiting for AMP instance to start...
amp [Notice] AMP instance ADS01 is now running.

Solution - ignore: "That message can be ignored, it’s not significant and doesn’t affect anything. It’s not an error (which are always prefixed with [Error])"

Reference:

Can't find custom attr constructor image - Technical Support / Installation Support - CubeCoders Support
https://discourse.cubecoders.com/t/cant-find-custom-attr-constructor-image/5079

pam_unix conversation failed - auth could not identify password for [amp]

Error in logs:

amp ampinstmgr[18466]: [Info] Waiting for AMP instance to start...
amp ampinstmgr[18466]: [Notice] AMP instance ADS01 is now running.
amp sudo[18522]: pam_unix(sudo:auth): conversation failed
amp sudo[18522]: pam_unix(sudo:auth): auth could not identify password for [amp]
amp ampinstmgr[18466]: [Info] 5e866903aa8a364105bcb010fed85f2382e4d8e208746bb81396604870d5ef97
amp systemd[1]: Finished AMP Instance Manager.

Solution: ??? Is anything actually broken, other than the service reports ending?

Reference:

Pam_unix(sudo:auth): auth could not identify password for [amp] - Technical Support - CubeCoders Support
https://discourse.cubecoders.com/t/pam-unix-sudo-auth-auth-could-not-identify-password-for-amp/537/2

keywords